Logstash agent is extremely slow, hangs for a while running grok filter

Description

The process is maxing out on CPU, but produces no output for a while. After some time it picks up for a little bit and then gets stuck again. It was flying with v.0.17. Until it's fixed, is there a way to use the old grok filter in v1.1.0?

Conf file:

Last messages in the console right before it hangs:

D, [2012-02-11T20:49:06.009000 #9803] DEBUG – : Running grok filter {"timestamp":"2012-02-11T20:49:06.900000 +0000","event":{"@source":"ip-11-88-27-215:/mnt/wxworx/log/nginx/wx_access.log","@type":"nginx-access","@tags":["gw"],"@fields":{},"@source_host":"ip-11-88-27-215","@message":"100.10.100.86 [11/Feb/2012:01:18:25 +0000] \"GET /2012-10-31/NjQzNTg4OWNP/reports/metar/nearest.json?lon=-93.690000&lat=43.623000&sig=4Q3oZE8_9HF75CnQ-t_tE-g18MI=&ts=1328923045392 HTTP/1.1\" 499 0 \"RPT-HTTPClient/0.3-3E\" : 59.855 - 10.4.241.95:9001 @ 1328923105.344","@timestamp":"2012-02-11T20:49:05.659000Z"},"message":"Running grok filter","file":"file","line":"/opt/logstash/logstash-1.1.0-monolithic.jar!/logstash/filters/grok.rb","method":"155","level":"debug"}
D, [2012-02-11T20:49:06.009000 #9803] DEBUG – : Trying pattern {"timestamp":"2012-02-11T20:49:06.900000 +0000","pile":"#<Grok:ile:0x1174031>","field":"@message","message":"Trying pattern","file":"file","line":"/opt/logstash/logstash-1.1.0-monolithic.jar!/logstash/filters/grok.rb","method":"165","level":"debug"}

Assignee

Jordan Sissel

Reporter

turisto

Labels

None

Affects versions

Configure