Debian packet privded break the system !!!

Description

Hi,

I have install logstash with the packet provided with the repository.
All went fine, but i try, now, to update my system, that's break the
system's update with:

insserv: warning: script 'nexus' missing LSB tags and overrides
insserv: There is a loop between service logstash and nexus if stopped
insserv: loop involving service nexus at depth 2
insserv: loop involving service logstash at depth 1
insserv: Stopping nexus depends on logstash and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header

Thanks to fix it quick !

Rgds,
Michaël Chlon

Activity

Show:
Jordan Sissel
January 20, 2014, 7:11 PM

I don't know what 'nexus' is but that seems to be your problem, not logstash.

michaëlC
January 20, 2014, 8:21 PM

In fact, after deleting the logstash packet, the full-upgrade ended well !
I have also remove the "nexus" init-script, that seems not to be fully debian compliant ...
I will see in the next few days, because i have reinstalled logstash debian
packet ...

Thanks for the reply.

michaëlC
January 23, 2014, 12:47 PM
Edited

In fact, it was an init script which was not fully LSB compliant !
It yields a loop ...

Assignee

Logstash Developers

Reporter

michaëlC

Labels

Affects versions

Configure