exception=>#<NoMethodError: undefined method `tv_sec' logstash 1.2.1 and 1.2.2

Description

Hi,

I hope someone can help.

I have a log form Log4Perl:

my logstash.conf

the error in logstash 1.2.1 and 1.2.2

Thanks
Andreas

Activity

Show:
Colin Surprenant
March 27, 2014, 8:34 PM

FYI, the proper fix for 1.4.0 has been merged https://github.com/elasticsearch/logstash/pull/1211

Piotr Machner
April 3, 2014, 1:43 PM
Edited

Hi, until this is fixed, is there any workaround to this issue? Downloading a development build? Or some older build (where to get them? On the main page there's just a link to the current version)? Anything?
I'm assuming that until this is fixed, it's not possible to use the multiline plugin, right?
Thanks in advance for any advice.

Colin Surprenant
April 5, 2014, 1:42 AM

Piotr,

If you are comfortable with working with a repo clone go ahead, master is stable. You can also download the latest built on https://s3-us-west-2.amazonaws.com/build.elasticsearch.org/origin/master/nightly/JDK7/logstash-latest.tar.gz.

Let us know if that help you.

Colin

Piotr Machner
April 7, 2014, 6:41 AM

Thank you Colin, yes, that's just fine for me
I'll let you know in case the fix doesn't help.
Thanks again,

Piotr

Piotr Machner
April 8, 2014, 7:13 AM

I was playing around for a couple of hours with the latest build yesterday and the fix worked for me.
I haven't spotted this error in that build.
Thank you, good job

Piotr

Assignee

Colin Surprenant

Reporter

Andreas Heidrich

Fix versions

Affects versions

Configure