Failed to flush outgoing items

Description

Trying to upgrade from 1.1.12 to 1.2. ES version is 0.90.2.

Current setup works fine as is but when I tried to upgrade, some logs get through to ES and the majority don't. The error in LS log is -

At the same time, the error in Elasticsearch log is -

Note that this setup works fine in Logstash 1.1.12 and I am unsure how to narrow down which config/logs are causing this from the 110 shippers I have.

Activity

Show:
Adrian Puente
December 12, 2013, 7:25 PM

I just tried 1.3.1 and I'm getting "Failed to flush outgoing items" errors processing Cisco ASA syslogs. So how is this fixed?

Jack Ruek
December 17, 2013, 1:12 AM

Same, also with 1.3.1 see

Jason Kendall
March 6, 2014, 4:19 PM

"Fixed in next release"

Is this fixed then?

Sergio R
March 6, 2014, 5:25 PM

@Jason, I don't experience this issue anymore, so, at least for me, I would say it is fixed. For the record, I'm using Logstash 1.3.3 and Elasticsearch 0.90.12.

Jason Kendall
March 6, 2014, 7:13 PM

Closing per comments.

Fixed

Assignee

Jason Kendall

Reporter

Former user

Fix versions

Affects versions

Configure